US and EU - CTC Developer portal experiencing access issues

Incident Report for CalAmp

Resolved

This incident has been resolved.
Posted May 27, 2026 - 15:39 PDT

Monitoring

The vendor has taken corrective action and continues to monitor and address any remaining performance issues.
Posted May 27, 2026 - 11:08 PDT

Update

The issue continues to be worked on by our vendor
Posted May 27, 2026 - 10:00 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 27, 2026 - 08:04 PDT
This incident affected: US CalAmp Telematics Cloud (US CTC Vehicle Services) and EU CalAmp Telematics Cloud (EU CTC Vehicle Services).