Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 18, 2025 - 19:00 PST
Update
Please disregard the previous message. This maintenance is still scheduled for tonight.
Posted Dec 18, 2025 - 11:31 PST
Update
This maintenance will be rescheduled for a later date.
Posted Dec 18, 2025 - 11:29 PST
Scheduled
A scheduled software release for CalAmp Telematics Cloud Reporting 2.79 (EU and US) will take place with no expected downtime. All other services will remain fully operational throughout the maintenance window below:
Thursday, December 18, 2025, between 7:00 PM - 10:00 PM PT (10:00 PM – 1:00 AM ET / 03:00 – 06:00 GMT on Friday, December 19).
Services affected: US CTC Admin US CalAmp App EU CTC Admin EU CalAmp App
Posted Dec 16, 2025 - 08:39 PST
This scheduled maintenance affected: US CalAmp Telematics Cloud (US CTC Admin), EU CalAmp Telematics Cloud (EU CTC Admin), and US CalAmp App, EU CalAmp App.