CTC EU - Degraded performance, message delay

Incident Report for CalAmp

Resolved

Issue resolved. Messages current.
Posted Mar 24, 2026 - 01:48 PDT

Identified

We have identified the issue, and corrective action has been taken. We are about 10 minutes behind and catching up.
Posted Mar 24, 2026 - 01:32 PDT

Investigating

We are currently investigating this issue.
Posted Mar 24, 2026 - 01:12 PDT
This incident affected: EU CalAmp Telematics Cloud (EU CTC Core Services).