CTC US - Degraded performance (Login and API)
Incident Report for CalAmp
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 06:28 PDT
Monitoring
The issue has been resolved. We are continuing to monitor.
Posted Jul 26, 2024 - 05:05 PDT
Investigating
We are currently investigating this issue.
Posted Jul 26, 2024 - 04:35 PDT
This incident affected: US CalAmp Telematics Cloud (US CTC Core Services, US CTC Admin) and US CalAmp App.