CTC EU - Degraded system performance
Incident Report for CalAmp
Resolved
This incident has been resolved.
Posted May 17, 2024 - 04:15 PDT
Investigating
We are currently investigating this issue.
Posted May 17, 2024 - 03:15 PDT
This incident affected: EU CalAmp Telematics Cloud (EU CTC Core Services).