K-12 Website Intermittent Access Issue

Incident Report for CalAmp

Postmortem

Started: 3/04/2025 02:57 pm ET
Corrective action: 3/05/2025 11:00 am ET
Event cleared: 3/05/2025 11:00 am ET

Problem Statement

Intermittent website availability from Wednesday, 3-6 PM ET and Thursday, 7-11 AM ET

Root Cause Analysis

On Tuesday, March 4, 2025, at approximately 2:57 PM ET, a user updated their department structure in our Time & Attendance software module.

The changes unintentionally created a circular dependency between two departments, leading to performance issues across our K12 applications.

This impacted website availability from Wednesday, 3:00 – 6:00 PM ET and Thursday, 7:00 – 11:00 AM ET.

Our team resolved the issue by removing the conflicting department link. Normal website performance was restored.

Corrective Action and Follow Up

  1. CalAmp is in the process of updating our services to prevent this circular dependency from happening in the future.
Posted Mar 14, 2025 - 04:32 PDT

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 09:02 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2025 - 08:43 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 05, 2025 - 08:38 PST

Investigating

Some users may experience errors or slow performance when logging into our K-12 platform. Our teams are actively working to resolve the issue as quickly as possible. We appreciate your patience and will provide updates as they become available.
Posted Mar 05, 2025 - 06:42 PST
This incident affected: Calamp K-12 (K-12 Website).