CalAmp iOn US - Degraded performance, Tracking page issue

Incident Report for CalAmp

Postmortem

iOn US – Tracking data display issue - 6/16/2026

Incident Date: 06/16/2026
Issue Started: 06/16/2026 08:20 am PT
Corrective action: 06/16/2026 10:20 am PT
Event declared over: 06/16/2026 10:47 am PT

Problem Statement

Tracking page not displaying in iOn.

Root Cause Analysis

A server in CalAmp’s iOn application experienced an internal communication issue that caused data to the tracking screens to stop displaying. No data was lost or delayed. This issue only affected the display of the data.

Once the communication between the services was restored, the display of data returned to normal.

Corrective Action and Follow-Up

  1. Communication was restored and monitored to ensure no further issues.
  2. Steps are being taken to identify and track these types of communication issues to mitigate future occurrences and to reduce the time to correct issues that should occur.
Posted Jun 18, 2026 - 14:41 PDT

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 10:25 PDT

Investigating

We are currently investigating this issue.
Posted Jun 16, 2026 - 09:06 PDT
This incident affected: US CalAmp iOn.