CTC US/EU Crashboxx is experiencing degraded performance
Incident Report for CalAmp
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 01:23 PDT
Monitoring
US Crashboxx is working and the team is working on EU.
Posted Jul 19, 2024 - 01:13 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 19, 2024 - 00:09 PDT
Investigating
We are currently investigating this issue.
Posted Jul 18, 2024 - 22:00 PDT
This incident affected: US CalAmp Telematics Cloud (US CTC Crashboxx Services) and EU CalAmp Telematics Cloud (EU CTC Crashboxx Services).