Crashboxx system performance degraded
Incident Report for CalAmp
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 08:24 PDT
Investigating
We are currently investigating this issue.
Posted Oct 01, 2024 - 07:32 PDT
This incident affected: US CalAmp Telematics Cloud (US CTC Crashboxx Services).