K12: GPS Processing Delays

Incident Report for CalAmp

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 17:05 PST

Update

We are continuing to investigate this issue.
Posted Mar 04, 2026 - 10:12 PST

Investigating

Some customers may currently experience delays in real-time vehicle location updates. This may temporarily affect location accuracy and Here Comes the Bus notifications. Our team is actively working to resolve the issue, and we will share updates as progress is made. Thank you for your patience and understanding.
Posted Mar 04, 2026 - 10:09 PST
This incident affected: Calamp K-12 (K-12 GPS Data Processing, K-12 Website, K-12 Here Comes the Bus).